Skip Navigation
 
Follow:
Facebook Twitter LinkedIn YouTube GooglePlus
Share:

Home  >  Education & Careers  >  eLearning Library

 

 

 

closeClose

 

Minimum system requirements for supported platforms

Pop-up blockers must be disabled in order to run IEEE Expert Now courses.

 
 

top of page

 

Windows 2000/NT/XP/2003

  • Internet connection 56K dial-up or faster
  • Internet Explorer 6.0
  • FireFox 1.5
  • Netscape 7.x or higher
  • Flash 7.0 or higher (Get Flash Player Now)
  • cookies, JavaScript, and Java enabled
  • processor: Pentium-class or higher
  • RAM - 128 MB
  • display settings: 1024x768 at thousands of colors
  • 16 bit sound card
  • mouse
  • speaker or headphones
  • Adobe® Reader® 5.0 or higher (Install Now)
  • Windows Media Player 9 or higher

 
 

top of page

 

Mac OS 9.0, OS X, and above

  • Internet connection 56K Dial up or faster
  • Internet Explorer 6.0
  • FireFox 1.5
  • Netscape 7.x or higher
  • Flash 7.0 or higher (Get Flash Player Now)
  • Apple Java 1.4.2 - 1.5.04
  • cookies, JavaScript, and Java enabled
  • processor: Power PC G3 or higher
  • RAM - 128 MB
  • display settings: 1024x768 at thousands of colors
  • Mouse
  • speaker or headphones
  • Windows Media Player 9 or higher

 
 

top of page

 

Other platforms, i.e., RedHat, Linux, and Solaris

    • Internet connection 56K dial-up or faster
    • Netscape 7.x or higher
    • Cookies, JavaScript enabled
    • processor: Pentium-class or UltraSPARC II or higher
    • RAM: at least 32 MB (over and above OS requirements)
    • display settings: 800x600 resolution (1024x768 recommended) at 16 bits per pixel or higher
    • mouse 

 
 

top of page

 

More information

Questions? Technical problems? Refer to the FAQ page or please contact Member Services

 
 

top of page